No Images in Social Media from posts posted through Hootsuite

  • Problem
  • Updated 6 months ago
  • Acknowledged
I am scheduling posts every three days to be posted in Facebook, Twitter and G+. The posts have images. When the thumbnail is generated in Hootsuite, the picture doesn't show in it. At first, I thought this happens because the fact that the posts in my blog are scheduled as well, and I thought the images will be visible in the social media selected as soon as the post will be live. It didn't happen. So, I tried the other method of uploading the image to Hootsuite and schedule, hoping it will show up. It didn't. So, right now, I have posts posted through Hootsuite but without images in Facebook and G+. How can I fix this?
Photo of Horatiu IoaniHI

Horatiu Ioani

  • 320 Points 250 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 26
Photo of Sterling

Sterling, Official Rep

  • 41,802 Points 20k badge 2x thumb
Official Response
Hello Everyone, 

Thank you for reaching out to us via the Community Forum! I know how frustrating it can be when your posts don't go out as intended. When posting your message the Social Network you are posting to determines the image that it will show. Facebook has a good example of this and a tool that you can use to help optimize your webpage to always display the correct image. Here is Facebook's Debug tool that you can use to see what images it will pull for your post. In the case of Facebook it can only pull from the first three images that it is showing in their tool. I recommend running your link through this tool to see what image your Social Network is going to see. 

I hope this answers the question of why an image shows up sometimes and sometimes not. If anyone has a particular issue about posting images directly from the Bulk Scheduler or the Compose Message box I encourage you to reach out to us @HootSuite_Help where we can help out with individual cases. 

Thank you everyone for your patience!

Sterling | @HootSuite_Help